PC freezes on installation

Discussion in 'Windows 7 Help and Support' started by Steve Scott, Apr 17, 2013.

  1. Steve Scott

    Steve Scott New Member

    Apr 17, 2013
    Likes Received:
    Hi there, I'm trying to install windows 7 on my PC (18 months old), I formatted the hard disk, placed the disk in etc. etc. and the installation runs through to the 'Completing Installation' part, where I can see it runs for a while because the ellipses scroll, then it freezes and I can't use the mouse at all. I've left it in this situation for about eight hours seeing if it'd repair itself but to no avail. I cannot boot w7 as it gives me an unexpected error. I haven't a clue what to do.

    AMD Phenom x4 965
    Radeon 6870
    4GB ram
    500gb HDD
    Asus M5A87 motherboard

    Would really be appreciated if I find a solution to this!
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Oct 16, 2009
    Likes Received:
    Before you tried the install, did you run the Upgrade Advisor?

    If you can access your system, the link below describes where some logs might be which could contain info about the failure.

    Windows 7, Windows Server 2008 R2, and Windows Vista setup log file locations

    But try removing everything you can from the system. If you have any external devices, remove those. And what kind of video connection do you have?
  3. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Mar 1, 2012
    Likes Received:
    The installation sometimes stalls. Disks are very important, I couldn't get Windows 7 installed with Windows directly with Windows, or with MiniTool Partition, but with gParted it worked, and not there with the first version.

    It's a task in the swamp. It either works, or not. You may get wet feet. Not more that I can give you, but sweat. :cool:
  4. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    May 25, 2009
    Likes Received:

    I've often found that just starting the process over will get it to work.
    Sometimes it just goofs up.

    I'd try that first anyway, it will only take a half hour or so and you will know if there is a real problem.

    Also if you can do as Saltgrass said and run Upgrade Advisor.
    It's possible that some component or driver isn't available for your computer, if you computer has something that Windows doesn't recognise.


Share This Page