saschaluescher

New Member
Hello :)

I have a Windows Server 2019 without direct access, so i can only control it remotely. The Server doesn't has a sound card or anything to make sounds, but i need to have audio on this server in order to have music in my live stream which i outsourced on this particular server. So i tried Virtual Audio cable and VB-Cable Virtual Audio Device to simulate audio. That didn't work on the server, but on my own pc (windows 10), it did. On my server they did show up in my device manager, but didn't show up in the playback devices or anywhere where i could use them. But i know that the reason isn't the operating system, because i tried to do the same on a Cloud windows 10 machine from Azure and there it wasn't working as well. But now i don't know what to do, in order to have sounds on this Server? I know that in order to have sounds you have to activate the corresponding windows services and i did that but it still doesn't . So could it be deactivated somewhere? Or something?

I would appreciate any idea on how to have sounds on this server. Thanks to everyone!
 

jesusMT

New Member
There are two basic steps which need to be taken to ensure audio is enabled on your Windows Server. Before beginning this process, please ensure that you are logged into the Administrator account on your Windows Server, so that the changes can be propagated to all of the user accounts if applicable.

The first step in this process ensures that the sound functions inside your Windows Server itself, completing this step alone will not ensure that the audio will be played through your personal computer.

1a)

  • Click on the start icon and scroll to programs
  • From programs, scroll down to Administrative tools
  • Select Terminal Services Configuration
1b)

  • Right click with your mouse on the RDP/TCP tab, and select properties.
  • De-select the box labled 'Disable Audio Mapping'
  • Proceed to step two in order to hear the audio through your local computer.
1c)

  • Click on the start icon and type tsconfig.msc -> Enter
  • Double click the connection
  • Go to 'Client Settings'
  • Uncheck the 'audio' checkbox
2)

  • From you local machine, open the 'Options' menu in Remote Desktop
  • Select the 'Local Resources' tab with the left mouse button
  • Locate the Remote Audio area, and choose 'Settings'
  • Go to 'Remote Audio Playback' and select 'Play on this computer'
  • Apply the changes and your Windows Server and local machine are ready for audio playback!


If you need to enable a microphone from your Local computer to be used on the server, follow these steps:

1) Open the 'Remote Desktop Connection' program
2) Click 'Show Options' -> Local Resources -> Remote audio ->Settings -> Remote Audio Recording -> check Record from this computer.

Save those settings and then reconnect to Remote Desktop
 
Top