Random Freezes

Hey, had another BSOD today, again with athrx.sys
Just uninstalled Symantec after it... and installed MSE.
Is there a chance there is a problem in Alt.Binz 0.31.6
Just noticed that during the BSOD's that program was downloading every time. Although it's on quite alot, so not sure if it can cause the problem (obviously downloading using the wireless card and therefor athrx.sys, so might be just the wireless use and not especially the program)

(minidump included again)


Last edited:
Yep, wireless driver is bugging out. Great that you removed Norton (in safe mode with the tool I hope.) It is the very likely cause.


Not causing crashes at all, but you would do well to update:

1) NEC USB 3.0 driver from motherboard website:

2) Realtek HD Audio:

RTKVHD64 RTKVHD64.sys Tue Apr 20 04:46:52 2010


3) AMD video driver:

atikmdag atikmdag.sys Tue Jul 06 21:37:28 2010

Drivers & Support | GAME.AMD.COM

Hey, thanks again,

I didn't do it in safemode to be honest, but did ran the removal tool, should I run that one again in safe mode to be sure it got rid of everything?

As for the NEC USB 3.0 driver, neither ASUS nor Intel have an update for it at the moment, can't find any on NEC's site itself, and none newer in microsoft update catalog,

anyway, will post again if it crashes again, but hopefully not :p

PS: as for the ASMMAP64.sys (/BAK), do you know what it does? besides the fact it has something to do with the F/Fn buttons. although there are 3 more pre-installed programs like it; ATK Hotkey; ATK Media & ATKOSD2 and all my hotkeys seem to work fine. I still wonder if it isn't doing something important which I just don't trigger (much) or if it can hurt to not have the driver, but still have the service, even though it isn't started.

Last edited:
Yeah, ASUS has it. Find it on a different motherboard page from them if you need to. They're all the same driver for all boards. The latest is from April or even newer, of this year.

Yes, run the tool in safe mode to be sure it's all gone.

Thanks, did find one now, although it isn't a NEC driver anymore, it changed the listing of the device to Renesas (or something), seems the 2 componies fused, and the driver name therefor changed.

As for ASMMAP64.sys. I usually have my touchpad turned off through Fn+F9, and it would stay off if I reboot the laptop. Now it doesn't do so anymore, so I guess the driver saves some settings like that.


I had another one today, again while downloading, same BSOD as before.
it's added in the attachments again


Update the Suyin Camera driver from this link:

sncduvc sncduvc.SYS Mon Dec 29 04:14:26 2008

ASUSTeK Computer Inc.

Also from the link, update the Atheros lan driver:

L1C62x64 L1C62x64.sys Sun Dec 20 22:46:06 2009

According to the link, there is no Atheros wireless on your machine. Perhaps that's why the wireless is crashing on you. Try installing either the Intel or other wireless they have shown there.

Last edited:
Hey, thanks for the quick reply,

I tried to install the webcam driver, but it didn't allow me to install it, after checking in devince manager it showed I have the following installed:

Version v5.8.54000.0

Description Azurewave Camera Driver
Azurewave Camera Driver for Win7
(which comes from the same link you gave me)

LAN driver is updated now...

I tried to install the intel wlan driver, but couldn't run the install file, then tried the azurewave ones, the following one worked:
Version V8.0.0.238
Description Azurewave Wireless Lan Driver and Application

I noticed that in device manager it still shows atheros AR9285, and that this azurewave driver also uses athrx.sys (from 2009 though: version

So does this mean I actually don't have an atheros wlan card installed, but an azurewave one? and the fact it also uses an athrx.sys causes it to show up like atheros? So it looks like the driver updates while I was trying to fix the freezing issue before posting here got mixed up or so because device manager showed it was an atheros AR9285?

Found this topic where the last post explains a little. It seems the cards asus uses are made by azurewave, but use the chipsets from atheros, which obviously causes device manager to see it as the atheros one I guess? Seems though that I need to check with azurewave for updates and not with atheros? (assuming using this newly installed azurewave driver solves the problem, which I think it will)

Last edited:
Alright yeah, you have the Azurewave then. It uses the licensed driver from Atheros because it has their chip. Keep your fingers crossed, hopefully it will stay well now.

You're welcome.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.