Windows 8 (with windows 7 wifi driver) DNS server not responding

Discussion in 'Windows 8 Networking' started by sarah harris, Dec 12, 2013.

  1. sarah harris

    sarah harris New Member

    Joined:
    Dec 12, 2013
    Messages:
    5
    Likes Received:
    0
    My landlord upgraded to unlimited internet (through Rogers) and had to upgrade his modem as well. Since then, I have been unable to access the internet on my Lenovo Windows 8 computer (I have a Windows 7 wireless driver due to a previous problem-see Cisco incompatibility issue: support.microsoft.com/kb/2749073/en-us). My 8 year old Dell with Windows XP connects to the internet just fine as does every other computer in the house (the landlord's and other tenants computers work just fine).

    Troubleshooting says the problem is the DNS server. Other forums have said that Rogers has crappy DNS servers, but since my XP gets internet just fine, there has to be some sort of problem other than that, right? My computer gets internet just fine at coffee shops, restaurants, libraries etc. so it's rather odd that it's the ONLY computer that does not work on the internet at home.

    We did an ipconfig /dnsflush and we got internet again for 3-4 days but my husband left town with the computer and when he came back, it wasn’t working again. I noticed windows did an update during that time so I did a system restore to before the update but it didn’t help. I’ve tried the dnsflush, and I’ve changed the preferred DNS servers but to no avail. I’ve downloaded a windows 8 driver again, and that didn’t do anything either so I’ve once again rolled back to the windows 7 wifi driver on a windows 8 system.

    I've also tried the following to no avail:

    1: run following command as administrator, then restart computer:
    netsh winsock reset
    2: try static IP address
    3: Reinstall network adapter driver from manufacturer’s website.
    4: Turn off IPv6 in Windows 8.
    5: Turn off power management on network adapter:

    Also, I don’t think it’s relevant but the internet is set-up so that we connect to an unsecure connection that then pops up a webpage with a pace to login (like a coffee shop or hotel) but the page doesn’t ever pop up even if I type in the URL and yet the computer claims that I’m connected. It also doesn’t matter which browser I use (IE, firefox, chrome), the problem persists.

    Here's a link to my ipconfig and windows tracing folder: https://skydrive.live.com/redir?resid=964C74E639BD0EF5!183&authkey=!AKvQMG1yvKH87ZQ&ithint=file%2c.zip

    Thanks for any help you can provide!
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Hello and welcome to the forum.
    I looked at your files and saw no ipconfig information.
    It's possible since you are connecting in the manner you've described above that Windows 8 may be associating the connection as either a public or guest network and the associated windows firewall (or third party firewall) may be set to block inbound and or outbound connections.
    Additionally there may be an issue with corruption regarding your wireless profile(s).
    Try reading this http://lifehacker.com/remove-wi-fi-profiles-from-windows-8-1-from-the-command-1449954864
    and blow away (delete) your wireless profile(s) especially any associated with the problem connection and start fresh.
    Lastly do an ipconfig /all on the problem machine and compare that information with the results of an ipconfig /all on one of the machines you mentioned above that seem to be working with issues.
    See what's different.
     
  3. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    What did you change them to? Try setting your DNS server address to the same as your default gateway address.
     
  4. sarah harris

    sarah harris New Member

    Joined:
    Dec 12, 2013
    Messages:
    5
    Likes Received:
    0
    Trouble, thank you for your response.

    I don't think the problem is the firewall, we've deactivated it numerous times but it has not helped. I tried deleting the wireless profile, but that did not work either.

    Here is the ipconfig /all for the problem computer (no internet):
    ipconfig all1.

    Here is the ipconfig /all for the working computer (not sure why it's not showing the wireless adapters but the internet is working - if you can shed any light, that would be great):
    ipconfig all working computer.JPG I just noticed the DNS servers are different on the two different computers, could that be the problem? Thanks for your help.




     
  5. sarah harris

    sarah harris New Member

    Joined:
    Dec 12, 2013
    Messages:
    5
    Likes Received:
    0
    Patcooke, we've tried a lot of different DNS server addresses including (but not limited to) the following:

    Preferred 208.67.222.222
    Alternate 208.67.220.220

    Preferred 8.8.8.8
    Alternate 8.8.4.4

    I've also tried changing it to the default gateway but that also did not help. Thanks for your assistance.
     
  6. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    You have two virtual wireless adapters (11 and 12). You may delete them.

    Setting the DNS address to that of the default gateway should cause your router to pass all DNS requests to your service provider and should therefore work in all circumstances.
     
  7. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Then my suggestion would be to set them manually to the DNS server IP addresses being used by the computer that seems to be functioning properly on your network and see if that makes any difference with connectivity.
     
  8. sarah harris

    sarah harris New Member

    Joined:
    Dec 12, 2013
    Messages:
    5
    Likes Received:
    0
    Trouble and Patcooke,
    I set my DNS server IP addresses (including the default gateway) to the same one's on the working computer. When that didn't work, I also changed the DNS servers addresses to the same one's on the working computer but nothing has worked thus far.

    ip change address.
     
  9. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    I've scanned through the thread (quickly I must admit!) and cannot see anything about trying DHCP - have you tried just allowing DHCP to set all your parameters? (obtain IP address automtaically and obtain DNS server address automatically)
     
  10. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    In your screen shot above you are (Command Prompt IPconfig) you're getting an APIPA address as if you are not receiving anything from your wireless router.
    After setting everything to automatic as patcooke suggested, look at the properties of your wireless adapter maybe under the advanced tab somewhere. I noticed that your Broadcom Adapter is being identified as an "N" adapter. That may be just a generic identifier and may mean nothing at all. However, check and make sure that it is set to also include "B" and "G" in case the wireless router is not capable of negotiating with an "N" only adapter.
     
  11. sarah harris

    sarah harris New Member

    Joined:
    Dec 12, 2013
    Messages:
    5
    Likes Received:
    0
    I set IP and DNS to obtain servers automatically and looked at the wireless adapter as suggested but it seems to be set correctly (IBSS mode is set to: 802.11b/g/n Auto). I don't know if it will help, but this is the ipconfig /all on the non-working computer when it has internet (it gets internet just fine at coffee shops, etc):

    ipconfig with internet.
     
  12. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Well ...... if it works every where else on the planet except with your landlord's new Roger's ISP provided device then I don't suspect there is much wrong with your end.
    The only thing I might suggest is, perhaps changing it from auto b/g/n to something else. Like b/g or b only or g only. Sometimes there is problems with devices auto negotiating and setting it manually will sometimes make a difference.
    Worth a try.
     
  13. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    With the ipconfig set as in your latest post goto a command prompt and see if each of the following three commands are successful:

    ping 10.1.28.1

    ping 206.191.0.140

    ping 206.191.0.210
     

Share This Page

Loading...