7-10 Upgrade installation stuck/hung


Honorable Member
Okay, so, I had both my desktop and my laptop (both running 7 Ultimate) registered for the free upgrade to 10; confirmed and everything.

It didn't seem like the background download was coming through (I read where it's supposed to be stored, and checked, and the folder was there but was only like 300 MB).

Then the GWX icon disappeared from my laptop, and the Windows Update screen no longer said anything about Windows 10. I tried a few tips on how to get GWX to work again, to no avail.

So I used MS's tool to download the ISO, dumped it to a thumb drive, and ran it on the laptop. Worked fine (posting from that now).

Then I tried using the same thumb drive on my desktop. It worked fine for the first step (verifying things, checking for updates, doing the first part of the install) up to the reboot. After it rebooted, it's been stuck on this screen (attached) for a couple of hours now. I even tried hitting the reset button (same shit when it came back up), and giving it a cold boot (also same).

Any ideas? Please halp!


Gave it another cold boot, and it booted back into 7. The Windows 10 setup app came up with an error:

We couldn't install Windows 10

0xC1900101 - 0x20017
The installation failed in the SAFE_OS phase with an error during BOOT operation

Last edited:


Honorable Member
Attempt #2. First restart about 3 minutes ago. We'll see what happens, I guess.


Honorable Member
Looks like it hung again. 45 minutes, and still on that same screen with the spinning dots. :/


Well-Known Member
I rebooted my system once during this process. Ultimately, had to remove my virus protection, and REATTEMPT the update.


Honorable Member
Left it overnight. Still there when i got up.

I rebooted my system once during this process. Ultimately, had to remove my virus protection, and REATTEMPT the update.
My AV was disabled, but it's Windows Defender, so I don't fully trust it to turn itself completely off. :/


Honorable Member
Realized I was conflating Defender with Microsoft Security Essentials; the latter was still active. Turned it off, tried again with a fresh download, left it running while I went on a 5-hour trip (to pick up a new bumper for my car). No luck.

Thinking about doing a clean re-install of 7, then trying to upgrade to 10 again.

Interestingly, after the first time I tried it, the GWX icon had disappeared from the tray, and wouldn't come back. After this last attempt? It's back.


Windows Forum Team
Staff member
Premium Supporter
I'd go to the Motherboard makers (whom so ever that is?) website and look for updated chipset drivers... and yes defender can block the install but it's almost always a driver issue.


Honorable Member
I think the problem may have been that, when installing Win7, I had used Audit Mode and an answers file to shove the /Users/ directory over to another drive (to save space on my SSD).

I wound up backing up all my shit (well, a few things seem to have gone missing, but only a few), doing a fresh install of Win7 without the Audit Mode trick, upgrading that to 10 to get my new product key, then wiping it again and doing a clean install of 10 and moving /Users/ again.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.