Desktop icons keep rearranging

Discussion in 'Windows 10 Help and Support' started by phantom16, Jun 16, 2016.

  1. phantom16

    phantom16 Well-Known Member

    Joined:
    Sep 18, 2013
    Messages:
    18
    Likes Received:
    4
    I have been having this issue for a couple weeks and it's really frustrating.

    I have an Acer 591G laptop that came with Windows 10 already installed, i.e. I didn't upgrade from a previous version.

    I can tell you that this issue only started happening a couple weeks ago, after I bought and started using a second monitor, which is a philips 220SW. Now it seems that about half the time I turn off or make my computer go to sleep, when I come back to the desktop, everything is put back in the top left corner.

    I have tried changing the resolution of my second monitor, I have made it so that icons aren't arranged to grids, and I have even gone into personalization>themes>desktop icon settings and ensure that the "allow themes to change desktop icons" box is unchecked. Nothing seems to make a difference.

    Does anyone have any ideas? have to rearrange all my desktop icons every second boot is getting terribly frustrating :)
     
  2. bochane

    bochane Honorable Member

    Joined:
    Oct 18, 2012
    Messages:
    643
    Likes Received:
    47
    Yes, how have you defined your second screen?
    You probably have defined it as a copy of your first screen. With it connected your computer is forced to used the smaller of the two sizes and rearrange the icons to that limitation, but without it can use the full size and rearranges the icons again.

    Try setting up the second screen as an extension of the first screen: right click on the desktop background, select display screen setting and look there.
    When set it up that way, you can move your mouse from one screen to the other by moving it over the adjacent border.
    In the setup screen you can pick up the 2nd screen an drag it to the location you want: left, right or above the main screen.

    Hope it is helping,
    Henk
     
    #2 bochane, Jun 16, 2016
    Last edited: Jun 16, 2016
  3. phantom16

    phantom16 Well-Known Member

    Joined:
    Sep 18, 2013
    Messages:
    18
    Likes Received:
    4
    Hey, sorry, I should have mentioned. I do have my second monitor set up as an extension, so I can do 2 different things at once. I thought the resolution on the second screen might play some effect (even though I have no icons on it), which is why I tried changing the 2nd monitor's resolution, but it didn't help. All my icons are on my actual laptop screen, and nothing is on the 2nd monitor, I just drag windows over there as I want.

    thanks for the suggestion though!
     
  4. bochane

    bochane Honorable Member

    Joined:
    Oct 18, 2012
    Messages:
    643
    Likes Received:
    47
    Than check in screen set up which of the 2 screens is your main screen, your Acer should be number 1
     
    #4 bochane, Jun 16, 2016
    Last edited: Jun 16, 2016
  5. phantom16

    phantom16 Well-Known Member

    Joined:
    Sep 18, 2013
    Messages:
    18
    Likes Received:
    4
    [​IMG]

    Seems to be the case :/
     
  6. bochane

    bochane Honorable Member

    Joined:
    Oct 18, 2012
    Messages:
    643
    Likes Received:
    47
    Has it something to do with the size of the icons? Try changing it 100%

    Has not your Philips screen a resolution of 1680 x 1050?
     
    BIGBEARJEDI likes this.
  7. phantom16

    phantom16 Well-Known Member

    Joined:
    Sep 18, 2013
    Messages:
    18
    Likes Received:
    4
    My philips does have a resolution of 1680 x 1050. That's what it was by default, but I changed it to a couple others in my experimenting.

    I kind of forgot about the 125% / 100% option. I will test that and see if it makes any difference in the next few days. thanks!
     
  8. bochane

    bochane Honorable Member

    Joined:
    Oct 18, 2012
    Messages:
    643
    Likes Received:
    47
    Keep my fingers crossed!
     
    phantom16 likes this.
  9. phantom16

    phantom16 Well-Known Member

    Joined:
    Sep 18, 2013
    Messages:
    18
    Likes Received:
    4
    I was wishing to simply edit my post and mention it as solved, and then PM Bochane to thank him for his help, but it doesn't seem that either option is possible for some reason. As much as I hate necroing an old thread, I would just like to say that Bochane's solution worked, and my desktop icons have stayed in place since reverting the scaling to 100%. Thanks!
     
  10. nmsuk

    nmsuk Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Sep 7, 2009
    Messages:
    2,697
    Likes Received:
    194
    Thank you for coming back and telling it is solved. This could be useful to another person in the future. So thank you
     
    phantom16 likes this.
  11. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,778
    Likes Received:
    214
    Nice work, Henk!! :up:
     
  12. bochane

    bochane Honorable Member

    Joined:
    Oct 18, 2012
    Messages:
    643
    Likes Received:
    47
    What a nice message!

    Henk
     

Share This Page

Loading...