Read Only problems!

Discussion in 'Windows 7 Help and Support' started by Starkman, Aug 5, 2013.

  1. Starkman

    Starkman New Member

    Joined:
    Feb 7, 2013
    Messages:
    27
    Likes Received:
    0
    Odd...having searched Google, I found hits for this forum, but I can't find anything searching within it!

    Anyway, all of a sudden all my folders are read-only. all files are shared within the folder, security settings are all fine, but no matter what I do it stays read-only.

    Another profile I created (which is not admin...the above being admin) does the same thing.

    Any ideas? Has MS addressed this sufficiently yet?

    The reason this is important for me to solve is that I can't transfer files from my main desktop to my laptop (using Homegroup, which has always worked) without getting the "unathorized" message.

    Thanks much,

    Starkman
     
    #1 Starkman, Aug 5, 2013
    Last edited: Aug 5, 2013
  2. Starkman

    Starkman New Member

    Joined:
    Feb 7, 2013
    Messages:
    27
    Likes Received:
    0
    Just refreshing. Any ideas, anyone?

    Thanks,

    Starkman
     
  3. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,884
    Likes Received:
    318
    Trouble is the networking guy on here, maybe he'll see this post and try to answer you questions for you.

    In the meantime try this, reboot your router by unplugging it from the wall AC power source for 2 minutes. Then plug it back in let it boot up, then check for issue.
     
  4. davidhk129

    davidhk129 Senior Member

    Joined:
    May 19, 2012
    Messages:
    1,337
    Likes Received:
    99
    Starkman,
    I don't have a definitive solution for you, just a question and a possible "workaround"..................

    Question :
    What does the Read Only box have ? A blue square or a checkmark.
    If it is not a checkmark, it is in essence NOT a "read only" attribute. In that case, your problem might be somewhere else.
    excerpt:
    “The Read-only attribute for a folder is typically ignored (!) by Windows, Windows components and accessories, and other programs. For example, you can delete, rename, and change a folder with the Read-only attribute by using Windows Explorer. The Read-only and System attributes is only used by Windows Explorer to determine whether the folder is a special folder, such as a system folder that has its view customized by Windows (for example, My Documents, Favorites, Fonts, Downloaded Program Files), or a folder that you customized by using the Customize tab of the folder’s Properties dialog box.”

    Possible "workaround" :
    Right click at the file or folder > select Take Ownership.
    When that is done, try the transfer again.

    If you do not have Take Ownership of file and folder in your right click context menu, here is a tutorial to install it.
    It is real easy.............
    http://www.vistax64.com/tutorials/112795-context-menu-take-ownership.html
    The tutorial is applicable to both Vista and Win 7.
     
    #4 davidhk129, Aug 11, 2013
    Last edited: Aug 11, 2013
    bassfisher6522 likes this.
  5. Starkman

    Starkman New Member

    Joined:
    Feb 7, 2013
    Messages:
    27
    Likes Received:
    0
    Thanks much, guys. I'll run the suggestions and get back to you all.

    Starkman
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I don't run HomeGroups, but there is a trouble shooter for it you might try.

    Have you changed anything in your HomeGroup as far as computers or being signed into the group, or any of the Advanced Sharing Settings?

    The exact type of message might be important in telling what is actually generating it.
     
  7. Starkman

    Starkman New Member

    Joined:
    Feb 7, 2013
    Messages:
    27
    Likes Received:
    0
    Well, first, the read-only box on the folder is shaded and has a checkmark.
    Second, I haven't changed anything with regard to Homegroup (in answer to Saltgrass's post).
    Third, I think I held ownership for everything, but I went ahead and downloaded and ran the right-click-take-ownership program.

    Checking the Security settings:
    Right-clicking on the folder in question > Properties > Security shows "Everyone," Authenticated users,"SYSTEM," "Administrators" and "Users (with my name), all showing full control and no checkmark in the Deny box.

    Under this same Properties windows, clicking on Advance:

    upload_2013-8-12_11-52-49.

    All the listings show here (there's nothing under below the last User entry, despite the scroll bar). As you can see, there are duplicates, and I'm not sure if that's good. Further, the first four do not no show inheritance. Even when I click on Change Permissions and enable both the 1) Include inheritable permissions... and 2) Replace all object child permissions... they simply won't take for those first four.

    I did, however, change the settings for the first entry (Admin (STARKMAN...): I clicked Change Permissions, highlighted the Admin account, clicked Edit and set the Apply To box to "This folder, subfolders and files" from "This folder only," as can be seen in the image below:
    upload_2013-8-12_11-58-33.

    Again, all the accounts, however, show full control, just as this Admin one does.

    Well, I rebooted, and I'm now copying over to my laptop from this file using Homegroup, and all seems to be working; however, there is still the shaded-checked Read Only box on the folder in questions and all subfolders, yet it seems to be copying.

    Though it may be working, are there any suggestions for cleaning any of this up, if that is necessary, or any other thoughts that come to mind?

    Thanks much,

    Starkman
     

Share This Page

Loading...