Sound Drivers For 7

Discussion in 'Windows 7 Hardware' started by kemical, Jan 23, 2009.

  1. kalleklovn

    kalleklovn New Member

    Joined:
    Dec 1, 2009
    Messages:
    4
    Likes Received:
    0
    @Kemical: thanks, but it did not help. I'm not shoure, but I think I need winamp, WMP, games... to work through ASIO4ALL. Is this possible?

    @Athlonite: But it worked superb on XP 32 bit, why not on 7 32 bit? must be something I can do or download to make it work? Its an superb sound card for me and I dont want to sell it.
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,821
    Likes Received:
    1,565
  3. animesector

    animesector New Member

    Joined:
    Dec 2, 2009
    Messages:
    2
    Likes Received:
    0
    No sound on ACER TRAVELMATE 4220

    I installed WINDOWS 7, and now I have No sound on ACER TRAVELMATE 4220! :( Does anyone know of a driver that will fi it? In device manager it states drivers are working and installed propertly.....but nada
     
  4. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,821
    Likes Received:
    1,565
  5. jarboy808

    jarboy808 New Member

    Joined:
    Nov 28, 2009
    Messages:
    8
    Likes Received:
    0
    Updating

    Hey all,

    With regards to the Creative Soundblaster 5.1 external surround card & Win 7 I was in contact with Creative & this was the official response;

    "With regards to your enquiry, there are no driver update for the X-Fi
    Surround 5.1 to run on windows 7. I would advice you to wait for the
    latest driver for the X-Fi Surround 5.1 on windows 7. You can check for
    latest update from our support site."

    http://support.creative.com

    So ahh...as always 3 months after a new OS hits Creative has no drivers for its products & the solution is "wait - then maybe".
     
  6. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,821
    Likes Received:
    1,565
    Thanks for the info Jarboy..:)
     
  7. Freshjms

    Freshjms New Member

    Joined:
    Dec 7, 2009
    Messages:
    4
    Likes Received:
    0
    No sound on Gateway MX6450

    Just recently installed Windows 7 Ultimate to find I have no sound! :frown: I then installed the updated Realtek AC97 sound drivers for Window 7 and that didn't help at all. Any advice?
     
  8. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,821
    Likes Received:
    1,565
    Have you tried windows update?
     
  9. Freshjms

    Freshjms New Member

    Joined:
    Dec 7, 2009
    Messages:
    4
    Likes Received:
    0
    Yeah. It says everything is up to date.
     
  10. linuxist

    linuxist New Member

    Joined:
    Dec 20, 2009
    Messages:
    2
    Likes Received:
    0
    I installed driveres and codecs and I stil don't have sound when I want to see a movie .But speakers work when I test it.Please a little help

    I have realtek
     
    #90 linuxist, Dec 20, 2009
    Last edited by a moderator: Dec 20, 2009
  11. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,821
    Likes Received:
    1,565
  12. Athlonite

    Athlonite New Member

    Joined:
    Mar 25, 2009
    Messages:
    792
    Likes Received:
    10
    looks like you maybe SOL tryin to find win7 drivers for that as gateway don't even list a sound driver when you choose any OS other than winxp on their site hmmm have tries the latest realtek drivers which are at Version: 6305
     
  13. nickauger

    nickauger New Member

    Joined:
    Dec 27, 2009
    Messages:
    2
    Likes Received:
    0
  14. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,821
    Likes Received:
    1,565
  15. nielsfeddema

    nielsfeddema New Member

    Joined:
    Jan 7, 2010
    Messages:
    22
    Likes Received:
    0
    Hi,

    Just like everyone else here, my soundcard doesn't seem to be working.
    I've got an 'Asus P5GL-MX' motherboard.
    Could you help me out with this?

    thanks in advance.
     
  16. Athlonite

    Athlonite New Member

    Joined:
    Mar 25, 2009
    Messages:
    792
    Likes Received:
    10
    just once i'd like to see a post that actually tells you what piece of hardware they are actually lookin for take the above post for example so we know you've got an Asus P5GL-MX mobo:confused: but you failed to say that the sound chip on it is an ADI SoundMax AD1986A:redface: i mean how are we supposed to help if you don't even tell us what actual piece hardware your lookin for is and end rant.....

    now as for a driver as far as i know Analogue Devices has no plans to update the drivers for this chip anytime soon so unless an oem is going to do so you may be SOL time to look at getting an add-in pci sound card like and SB audigy 2 or better
     
  17. nielsfeddema

    nielsfeddema New Member

    Joined:
    Jan 7, 2010
    Messages:
    22
    Likes Received:
    0
    Thanks for the help.
     
    #97 nielsfeddema, Jan 9, 2010
    Last edited: Jan 11, 2010
  18. nielsfeddema

    nielsfeddema New Member

    Joined:
    Jan 7, 2010
    Messages:
    22
    Likes Received:
    0
    Got myself a new soundcard, this time it's an ICIDU soundcard with a C-Media chipset.
    http://icidu.com/ProductDetail.aspx?pd=1312684

    When connected to the normal line plug it's working, but as I connect it to the 7.1 channels it doesn't.
     
  19. Athlonite

    Athlonite New Member

    Joined:
    Mar 25, 2009
    Messages:
    792
    Likes Received:
    10
    Operating system/software Compatible operating systems Windows 98SE/2000/XP/Vista

    yup i wouldn't have touched a card that says anything about win98\win2k support what you should be looking for is XP\Vista\Win7 support

    does the speaker system you use have and SPDIF input
     
  20. nielsfeddema

    nielsfeddema New Member

    Joined:
    Jan 7, 2010
    Messages:
    22
    Likes Received:
    0
    ah ok, didn't know that..

    No, the speaker system doens't have an SDPIF input.
     

Share This Page

Loading...