ELAN Touchpad Driver

Curious

Extraordinary Member
#1
WINDOWS 10

Windows Update installs today the update "ELAN Touchpad 15.9.5.3_X64_WHQL from ELAM Microelectronic Corp.".

After the installation i boot the computer and the look of the icon of "ELAN Pointing Device" changed.

The touchpad is enable, and before this update he stay disable because i customize in Properties saying:

"When using Mouse i want the touchpad disable".

Now, i need to call "ELAN property of touch-pad", and in "ELAN" choose "Stop Device".

The problem is that i need to make this change every time i boot the computer.

Someone can help me about this?

Thank you and best regards
Curious
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#2
Hi,
try going into Device manager and rolling back the driver.
 


Curious

Extraordinary Member
#3
Hi,
try going into Device manager and rolling back the driver.
This is the first procedure i made and the result was the same.
I think i have to uninstall the driver from Control Panel ant then install a version before that one.
I´m afraid to do this, thus is better to wait for a solution for the problem by Microsoft.
Thanks for your answer.
 


#4
I had the same problem, tho the option has dissapeared from the mouse-settings, you can still change it in your Windows Registry.
Warning : you need to have some registry knowledge, it's important to backup your registry first to avoid causing problems with your Windows Installation.

1: Right click the start-button and select "Run" Type "Regedit.exe" and press enter.
2: Navigate to the following registry path "HKEY_CURRENT_USER\Software\Elantech\OtherSetting"
3: Find the name "DisableWhenDetectUSBMouse" and change D-Word value from "0" to "1"
4: Close Regedit and Sign-out from Windows, then sign back in to load the new mouse-settings.

If it doesn't work, also navigate to this registry path "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Elantech\OtherSetting" and repeat step 3.

Let me know how this works out for you :)
 


Curious

Extraordinary Member
#5
I had the same problem, tho the option has dissapeared from the mouse-settings, you can still change it in your Windows Registry.
Warning : you need to have some registry knowledge, it's important to backup your registry first to avoid causing problems with your Windows Installation.

1: Right click the start-button and select "Run" Type "Regedit.exe" and press enter.
2: Navigate to the following registry path "HKEY_CURRENT_USER\Software\Elantech\OtherSetting"
3: Find the name "DisableWhenDetectUSBMouse" and change D-Word value from "0" to "1"
4: Close Regedit and Sign-out from Windows, then sign back in to load the new mouse-settings.

If it doesn't work, also navigate to this registry path "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Elantech\OtherSetting" and repeat step 3.

Let me know how this works out for you :)
Hello,
It works perfectly, thanks.
I change the two registries.
Best regards
Curious
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#6
Nice job Trackah!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.