Network connection but no internet.

#1
I have searched a number of these threads and it seems this is a regular problem but also seems like one that is difficult to resolve. I have used the same modem/router for a while with no issues, then suddenly one day, there is no internet via the wifi. Connection to network is fine and I can see network attached devices, but no internet.

I fixed the problem temporarily by using a cable to connect directly to a port on the router, but after a few days, this failed also.

Have tried different networks with the same result ( network connection but no internet). Spent half an hour on the phone with my isp support messing with DNS settings, but still no fix. They suggested it was a windows update issue and I would have to contact windows.

Would appreciate any suggestions that can be offered.

Thanks
 


bochane

Honorable Member
#3
Yes, a common problem, hard to solve, I too have been strugling with it.

So far I found:
- Make sure that you have only one network in reach that is autoconnectable.
You have at home your privat network that is autoconnectables, and maybe a second network to be used as wireless access point for all clients of your Internet provider. I see here a Ziggo_xxxx (my privat network) and a Ziggo network, both come from my modem. Don't make that 2nd network also autoconnectable.

- Adapter settings.
Sometimes the adapter setting need to be adjusted. Go to the Device control, than WiFi Adapter, Propeerties, Advanced tab
Of special interest are:
- 802.11n modus
- standard wireless ad-hoc modus
- wireless modus
 


ussnorway

Windows Forum Team
Staff member
Premium Supporter
#4
I fixed the problem temporarily by using a cable to connect directly to a port on the router, but after a few days, this failed also.
Looks like a dhcp error to me… is that 192.168.0.101 address reserved for you in the router or just assigned as the next available number?
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#5
I would ask about the DNS address. Different routers handle that address differently so it may be correct, just hard to say. Sometimes they pass an address through, which may be an option on the router, but on most I have seen they use the address of the router.

Have you tried setting the Google DNS servers to see if that helps?

Oh, next time you need to attach some information, you can copy and insert information from the command prompt, or use the snipping tool to take a picture and attach.
 


Trouble

Noob Whisperer
#6
It mostly looks good to me except for a single DNS server address in the IPconfig information which is apparently the router as that same address is listed as DHCP Server and Gateway.
I would go with Saltgrass and add manual / static DNS assignments to Google's Public DNS servers
8.8.8.8
AND
8.8.4.4
See if that helps. Sometimes, some routers just seem to balk at forwarding for DNS resolution.
 


#7
what could cause a system to see a server on the network but cannot communicate
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#8
Have you tried the Troubleshooter? If it won't run I will try to find instructions on how to start it manually.

Have you tried pinging both a URL and IP address to see if one will complete and one won't. This might help diagnose a DNS problem.

You have rebooted your system, which means Modem/Router/computer/kitchen sink?

If your wireless is getting to your router but can't get to the internet, it might be something related to settings involved in that portion, such as the DNS.

Are you using a cable Gateway type device?

Edit: Would you have any reason to believe Vodafonemobile was involved?
 


Last edited:

bochane

Honorable Member
#9
what could cause a system to see a server on the network but cannot communicate
-The router part of the modem: the routing tables may be corrupt. As suggested reset - power off / wait / on - the modem

- The DNS server: on your pictures it was something like 10.19.0.1, I am not sure and I may be wrong, but I thought all 10.x.x.x numbers are privat and only valid on internal networks and your current internal network is 192.168.x.x. If I am true, that won't work! As suggested try Googles Public DNS Servers, and make sure that in the TCP/IP v4 settings Automatic is selected and not something else

- Your Internet Service Provider may have blocked you

- I can't explain it, but I have seen that if you have 2 WiFi networks in reach both set to autoconnect, things seem to get mixed up, resulting in no internet connection (but in that case you should have internet when you plug in your lan cable, but even that did not help)

- There must be more....

Hope it helps a little bit,
Henk
 


Last edited:

ussnorway

Windows Forum Team
Staff member
Premium Supporter
#10
- There must be more....
Time snyc is a big one... i.e if the system clock is way off that stops the hand shake.
A fire wall is also possible but you would know if you had set one of them up?
 


#11
thanks to y'all it was actually a browser problem
 


#12
This is an issue for me too
 


bochane

Honorable Member
#13
This is an issue for me too
Could you tell us a bit more? Without further info we can't help.

Other points on the above list:
- Your TCP/IP settings may be wrong: most times you should select automatically get an IP and DNS address

- Wireless Adapter settings: in the advanced options the channel settings: try automatic and ad-hoc channel to 1
 


Last edited:
#14
the problem is solved already,
 


#15
Hello, I'm having similar problem, but with a new laptop. The only time the internet was available on the laptop was when I changed to the Google DNS server (but only for minute or two)... The wifi - with strong signal even - says connected, but browser (both desktop and start screen app) says "page cannot be displayed".
What is interesting though, there is another w8.1 laptop in my household with wifi issues as well, but reset solves the problem. (Not on my laptop though) I also have windows phone that connect to wifi, but hasn't an internet access. My father's computer with Vista and my old laptop with w7 works fine. I guess windows 8 is kinda picky with wifi connection. Should I try to do something with router settings? At the moment I have set 802.11n, channel auto and 20/40MHz bandwidth. (I think these are the most important?)

Anyway, ipconfig
ipconfig.png

(I hope the foreign language doesn't matter, I couldn't find a good support)

Thanks for help in advance.
 


Last edited:

bochane

Honorable Member
#16
Is the router using a 5GHz network? Some older devices don't support it.
Try using mode B/G/N 20MHz only as wel in the router as in the WiFi adapter of the laptop (see Devices > Network adapters > Intel).
 


Last edited:
#17
Thanks for reply,
the router is not using 5GHz network. I set the mode to b/g/n 20MHz, but I found out the laptop only has a, b, g, b/g, a/g or a/b/g settings. I tried using the a/b/g, which made my connection limited.
 


bochane

Honorable Member
#18
The 2.4 GHz band is usually overloaded. You can monitor with a program like inSSIDer. Here in my house I see at least 30 networks all using the same 13 channels
Maybe you have to live with the limitations of A/B/G mode 20MHz single.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.