SOLVED HP S5780uk can't detect wireless networks

Discussion in 'Windows 7 Help and Support' started by conundrum, Aug 11, 2014.

  1. conundrum

    conundrum Senior Member

    Joined:
    Nov 2, 2011
    Messages:
    49
    Likes Received:
    0
    Hi, I've encountered a problem with a HP S5780uk desktop. The wireless adapter is showing no networks available, device manager reports it as working fine, I've disabled and enabled it several times, reinstalled the drivers, and temporarily turned off the firewall then disabled and enabled it again, with no success. The same computer has had a problem with norton 360 v5 for some time, it wouldn't open or do any scans, so I uninstalled it, again without the wireless problem being solved. I haven't noticed any obvious signs of a virus on the system.

    Another computer in the same location reports a number of wireless networks available, and connects to the ineternet wirelessly, so it's not the router that's the problem. I'm thinking the wireless adapter might have a hardware fault, but is there anything else that I could try? The adapter is from "Ralink Technology, Corp." and identifies itself as "802.11n Wireless LAN Card".

    I did a quick search for similar threads before posting, if I've missed anything then apologies in advance.
     
  2. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    If you have had Norton on your computer or any other software security suite other than Microsoft Security Essentials I would strongly suggest running the vendor specific proprietary removal tool to eliminate any possible remnants.
    The one for Symantec / Norton products is here https://support.norton.com/sp/en/us/home/current/solutions/kb20080710133834EN_EndUserProfile_en_us
    You can Google for a similar tool for McAfee, AVG, etc.,
    After completing that also double check the properties of the Network Card you are using and confirm that in the "This connection uses the following items:" box there is no reference to a third party security product.
    Additionally check device manager, click the View tab from the menu bar and select show hidden devices and make sure, likewise, there is no reference to any third party security product.
     
  4. conundrum

    conundrum Senior Member

    Joined:
    Nov 2, 2011
    Messages:
    49
    Likes Received:
    0
    Thanks for the advice, I'll post back with the results.
     
  5. conundrum

    conundrum Senior Member

    Joined:
    Nov 2, 2011
    Messages:
    49
    Likes Received:
    0
    SOLVED. This took a while. I didn't find any references to 3rd party security products in the device manager hidden items or in the properties for the network adapter. I disabled power saving and restarted it without success. A new adapter had the same problem. Eventually I just tried SFC /scannow from an admin command prompt. That fixed the connection.

    Then I found the likely cause, the system had media view, conduit search, better surfing, and a bunch of other malware, so once the system got online they started to pop up all over the browser. Windows defender couldn't run, nor could on screen keyboard or ccleaner, and a load of options and files were access denied to the admin account, even after taking ownership.

    Taking off the malware required AVG, ccleaner, going into safe mode to delete the conduit folder from appdata, then malwarebytes anti-malware to remove the >300 registry entries that were still left over. The system seems to be clean now. Thanks again for your help, and hopefully this thread might be usefull to the next person to get this problem.
     
  6. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
    I'm glad it's solved, it's the kind of music that melts my heart.

    The biggest problem today may well be all the extras one gets when installing a software; we're used to press I accept and OK and in the heat of the moment, we don't notice what we got, altogether. Who really reads all the copyright etc. texts? Must admit, I don't... :redface:

    Great you got it fixed, and great you gave the feedback. :up:
     

Share This Page

Loading...